We’ve received an update from Telnet about the phone and data issues we experienced on Friday, 11/14/25. Telnet confirmed there was a problem with the connection entering our network, but this has now been resolved. The service has been stable since 1:18 PM on Saturday, 11/15/25.
They made some changes to the way the traffic is routed, and that update is still in place. Everything should be running smoothly now, but we’re still keeping an eye on it to make sure it stays that way.
We’re closing the incident for now, but we’ll continue to monitor our phone system for any lingering issues.
Posted Nov 17, 2025 - 09:09 EST
Update
We have not heard anything from Telnet since last update on Friday 11-14-25. Until Telnet provides a full resolution or If we do not have any reported issues today we will resolve this status. We apologize for any inconvenience this has caused.
Posted Nov 17, 2025 - 07:05 EST
Update
Telnet has removed the routing path to the affected carrier causing the issue. They are stating this change should resolve the majority of issues. As this is not a complete resolution we will leave our status in monitoring until we have full confirmation of resolution.
Posted Nov 15, 2025 - 09:46 EST
Update
Telnet has finally contacted us. They stated the underlying issue is still NOT resolved, but they have taken steps to help mitigate the issue. Telnet currently has not ETTR on full resolution.
Posted Nov 14, 2025 - 16:28 EST
Monitoring
We have reports that the underlying issue has been resolved, but we have not received any contact from Telnet with confirmation. We will continue to monitor the system until further notice.
Posted Nov 14, 2025 - 15:10 EST
Identified
Our carrier Telent is experiencing issues with no current ETA for resolution.
Posted Nov 14, 2025 - 12:01 EST
Investigating
We are currently experiencing intermittent issues with incoming calls originating outside our phone system.
The SCCRESA IT Helpdesk is working to identify the root cause and implement a solution.
Please email the Helpdesk at helpdesk@sccresa.org if you are unable to reach us via phone.
Posted Nov 14, 2025 - 11:52 EST
This incident affected: General Announcement and Phone Service (Mitel, TelNet WW - SIP).